$re = '/\/\*[^*]*\*+([^\/*][^*]*\*+)*\/(*SKIP)(*F)|^(\w+)\s*=\s*(\w+)/m';
$str = '/*
anything description
*/
Data1 = value1;
Other_Data = Other_Value;
/*
my other description
*/
Anything = Any_Answer;
/*
this is description and must not detect
Description_Data = Any_Value;
*/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);