re = /\/\*[^*]*\*+([^\/*][^*]*\*+)*\/(*SKIP)(*F)|^(\w+)\s*=\s*(\w+)/m
str = '/*
anything description
*/
Data1 = value1;
Other_Data = Other_Value;
/*
my other description
*/
Anything = Any_Answer;
/*
this is description and must not detect
Description_Data = Any_Value;
*/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end