import re
regex = re.compile(r"\/\*[^*]*\*+([^\/*][^*]*\*+)*\/(*SKIP)(*F)|^(\w+)\s*=\s*(\w+)", flags=re.MULTILINE)
test_str = ("/*\n"
"anything description\n"
"*/\n\n"
"Data1 = value1;\n\n"
"Other_Data = Other_Value;\n\n"
"/*\n"
"my other description\n"
"*/\n\n"
"Anything = Any_Answer;\n\n"
"/*\n\n"
"this is description and must not detect\n\n"
"Description_Data = Any_Value;\n\n"
"*/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")