import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\"?testing ((?!L?\"?$).*?)\"?$";
final String string = "testing rest\n"
+ " -> matches (rest)\n"
+ "testing what\"\n"
+ "\"testing what\"\n"
+ " -> matches (what)\n"
+ "testing Loong\n"
+ "testing Loong\"\n"
+ " -> matches (Loong)\n"
+ "testing N\n"
+ "\"testing N\"\n"
+ " -> \n"
+ "testing L\n"
+ "testing L\"\n"
+ " -> this is not matched\n"
+ "testing\n"
+ " -> this is not matched\n"
+ "testing \n"
+ "-> this is not matched";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}