const regex = /^"?testing ((?!L?"?$).*?)"?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^"?testing ((?!L?"?$).*?)"?$', 'gm')
const str = `testing rest
-> matches (rest)
testing what"
"testing what"
-> matches (what)
testing Loong
testing Loong"
-> matches (Loong)
testing N
"testing N"
->
testing L
testing L"
-> this is not matched
testing
-> this is not matched
testing
-> this is not matched`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}