#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?Um)<div class=\"article\">.*href=\"((.|\n)*)\">"
Local $sString = "<div class="article">" & @CRLF & _
" <div class="article__time">" & @CRLF & _
" 22:57" & @CRLF & _
" </div>" & @CRLF & _
"<div class="article__title">" & @CRLF & _
" <a href="https://www.eurointegration.com.ua/rus/news/2018/07/13/7084390/" target="_blank">Трамп: аннексия Крыма - это катастрофа Обамы" & @CRLF & _
"</a>" & @CRLF & _
"</div>" & @CRLF & _
"<div class="article__subtitle">" & @CRLF & _
"Президент США Дональд Трамп назвал аннексию Крыма катастрофой своего предшественника Барака Обамы, отметив, что это одна из проблем, которые перешли в наследство и которые он пытается уладить.</div></div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")