# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<div class=\"article\">.*href=\"((.|\n)*)\">"
test_str = ("<div class=\"article\">\n"
" <div class=\"article__time\">\n"
" 22:57\n"
" </div>\n"
"<div class=\"article__title\">\n"
" <a href=\"https://www.eurointegration.com.ua/rus/news/2018/07/13/7084390/\" target=\"_blank\">Трамп: аннексия Крыма - это катастрофа Обамы\n"
"</a>\n"
"</div>\n"
"<div class=\"article__subtitle\">\n"
"Президент США Дональд Трамп назвал аннексию Крыма катастрофой своего предшественника Барака Обамы, отметив, что это одна из проблем, которые перешли в наследство и которые он пытается уладить.</div></div>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.