// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?Um)<div class=\"article\">.*href=\"((.|\n)*)\">"#).unwrap();
let string = "<div class=\"article\">
<div class=\"article__time\">
22:57
</div>
<div class=\"article__title\">
<a href=\"https://www.eurointegration.com.ua/rus/news/2018/07/13/7084390/\" target=\"_blank\">Трамп: аннексия Крыма - это катастрофа Обамы
</a>
</div>
<div class=\"article__subtitle\">
Президент США Дональд Трамп назвал аннексию Крыма катастрофой своего предшественника Барака Обамы, отметив, что это одна из проблем, которые перешли в наследство и которые он пытается уладить.</div></div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}