use strict;
my $str = '<div class="article">
<div class="article__time">
22:57
</div>
<div class="article__title">
<a href="https://www.eurointegration.com.ua/rus/news/2018/07/13/7084390/" target="_blank">Трамп: аннексия Крыма - это катастрофа Обамы
</a>
</div>
<div class="article__subtitle">
Президент США Дональд Трамп назвал аннексию Крыма катастрофой своего предшественника Барака Обамы, отметив, что это одна из проблем, которые перешли в наследство и которые он пытается уладить.</div></div>';
my $regex = qr/<div class=\"article\">.*href=\"((.|\n)*)\">/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}