import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div class=\\\"article\\\">.*href=\\\"((.|\\n)*)\\\">";
final String string = "<div class=\"article\">\n"
+ " <div class=\"article__time\">\n"
+ " 22:57\n"
+ " </div>\n"
+ "<div class=\"article__title\">\n"
+ " <a href=\"https://www.eurointegration.com.ua/rus/news/2018/07/13/7084390/\" target=\"_blank\">Трамп: аннексия Крыма - это катастрофа Обамы\n"
+ "</a>\n"
+ "</div>\n"
+ "<div class=\"article__subtitle\">\n"
+ "Президент США Дональд Трамп назвал аннексию Крыма катастрофой своего предшественника Барака Обамы, отметив, что это одна из проблем, которые перешли в наследство и которые он пытается уладить.</div></div>";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CHARACTER_CLASS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}