re = /<div class=\"article\">.*href=\"((.|\n)*)\">/m
str = '<div class="article">
<div class="article__time">
22:57
</div>
<div class="article__title">
<a href="https://www.eurointegration.com.ua/rus/news/2018/07/13/7084390/" target="_blank">Трамп: аннексия Крыма - это катастрофа Обамы
</a>
</div>
<div class="article__subtitle">
Президент США Дональд Трамп назвал аннексию Крыма катастрофой своего предшественника Барака Обамы, отметив, что это одна из проблем, которые перешли в наследство и которые он пытается уладить.</div></div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end