using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div class=\""article\"">.*href=\""((.|\n)*)\"">";
string input = @"<div class=""article"">
<div class=""article__time"">
22:57
</div>
<div class=""article__title"">
<a href=""https://www.eurointegration.com.ua/rus/news/2018/07/13/7084390/"" target=""_blank"">Трамп: аннексия Крыма - это катастрофа Обамы
</a>
</div>
<div class=""article__subtitle"">
Президент США Дональд Трамп назвал аннексию Крыма катастрофой своего предшественника Барака Обамы, отметив, что это одна из проблем, которые перешли в наследство и которые он пытается уладить.</div></div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}