#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*\/Title\(([^\)]*)\).*"
Local $sString = "randomtestdata 4012 obj<</Title(Here is my title)/CreationDate(D:5423415)>>" & @CRLF & _
"randomtestdata 4012 obj<</CreationDate(D:5423415)/Title(Here is my title)>>" & @CRLF & _
"randomtestdata 4012 obj/Title(Here is my title)<</CreationDate(D:5423415))>>" & @CRLF & _
"randomtestdata/Title(Here is my title) 4012 obj<</CreationDate(D:5423415))>>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")