package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\/Title\(([^\)]*)\).*`)
var str = `randomtestdata 4012 obj<</Title(Here is my title)/CreationDate(D:5423415)>>
randomtestdata 4012 obj<</CreationDate(D:5423415)/Title(Here is my title)>>
randomtestdata 4012 obj/Title(Here is my title)<</CreationDate(D:5423415))>>
randomtestdata/Title(Here is my title) 4012 obj<</CreationDate(D:5423415))>>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}