import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\/Title\\(([^\\)]*)\\).*";
final String string = "randomtestdata 4012 obj<</Title(Here is my title)/CreationDate(D:5423415)>>\n"
+ "randomtestdata 4012 obj<</CreationDate(D:5423415)/Title(Here is my title)>>\n"
+ "randomtestdata 4012 obj/Title(Here is my title)<</CreationDate(D:5423415))>>\n"
+ "randomtestdata/Title(Here is my title) 4012 obj<</CreationDate(D:5423415))>>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}