use strict;
my $str = 'randomtestdata 4012 obj<</Title(Here is my title)/CreationDate(D:5423415)>>
randomtestdata 4012 obj<</CreationDate(D:5423415)/Title(Here is my title)>>
randomtestdata 4012 obj/Title(Here is my title)<</CreationDate(D:5423415))>>
randomtestdata/Title(Here is my title) 4012 obj<</CreationDate(D:5423415))>>';
my $regex = qr/.*\/Title\(([^\)]*)\).*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}