// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*\/Title\(([^\)]*)\).*").unwrap();
let string = "randomtestdata 4012 obj<</Title(Here is my title)/CreationDate(D:5423415)>>
randomtestdata 4012 obj<</CreationDate(D:5423415)/Title(Here is my title)>>
randomtestdata 4012 obj/Title(Here is my title)<</CreationDate(D:5423415))>>
randomtestdata/Title(Here is my title) 4012 obj<</CreationDate(D:5423415))>>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}