re = /.*\/Title\(([^\)]*)\).*/
str = 'randomtestdata 4012 obj<</Title(Here is my title)/CreationDate(D:5423415)>>
randomtestdata 4012 obj<</CreationDate(D:5423415)/Title(Here is my title)>>
randomtestdata 4012 obj/Title(Here is my title)<</CreationDate(D:5423415))>>
randomtestdata/Title(Here is my title) 4012 obj<</CreationDate(D:5423415))>>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end