const regex = /.*\/Title\(([^\)]*)\).*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\\/Title\\(([^\\)]*)\\).*', 'g')
const str = `randomtestdata 4012 obj<</Title(Here is my title)/CreationDate(D:5423415)>>
randomtestdata 4012 obj<</CreationDate(D:5423415)/Title(Here is my title)>>
randomtestdata 4012 obj/Title(Here is my title)<</CreationDate(D:5423415))>>
randomtestdata/Title(Here is my title) 4012 obj<</CreationDate(D:5423415))>>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}