# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\d+\.\s*//gm;t' <<< "01. Item1
02.Item3
3D Item
Item next"