package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+\.\s*`)
var str = `01. Item1
02.Item3
3D Item
Item next`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}