#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\d+\.\s*"
Local $sString = "01. Item1" & @CRLF & _
"02.Item3" & @CRLF & _
"3D Item" & @CRLF & _
"Item next"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)