re = /^\d+\.\s*/m
str = '01. Item1
02.Item3
3D Item
Item next'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result