use strict;
my $str = '01. Item1
02.Item3
3D Item
Item next';
my $regex = qr/^\d+\.\s*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";