$re = '/^\d+\.\s*/m';
$str = '01. Item1
02.Item3
3D Item
Item next';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;