const regex = /^\d+\.\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+\\.\\s*', 'gm')
const str = `01. Item1
02.Item3
3D Item
Item next`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);