#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^ADOI.*OP_.*\txt$"
Local $sString = "ADOI1OP_2.txt"
Local $sSubst = "($1$2$3) $4$5$6-$7$8$9$10"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)