const regex = new RegExp('^ADOI.*OP_.*\\txt$', 'mg')
const str = `ADOI1OP_2.txt`;
const subst = `($1$2$3) $4$5$6-$7$8$9$10`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);