using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ADOI.*OP_.*\txt$";
string substitution = @"($1$2$3) $4$5$6-$7$8$9$10";
string input = @"ADOI1OP_2.txt";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}