$re = '/^ADOI.*OP_.*\txt$/m';
$str = 'ADOI1OP_2.txt';
$subst = "($1$2$3) $4$5$6-$7$8$9$10";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;