use strict;
my $str = 'ADOI1OP_2.txt';
my $regex = qr/^ADOI.*OP_.*\txt$/mp;
my $subst = '($1$2$3) $4$5$6-$7$8$9$10';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";