re = /^ADOI.*OP_.*\txt$/m
str = 'ADOI1OP_2.txt'
subst = '($1$2$3) $4$5$6-$7$8$9$10'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result