#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\h*[^ a-zA-Z\n].*$"
Local $sString = "Go Forty Go (IRE) 471" & @CRLF & _
"Pearl Noir 15528258 D3" & @CRLF & _
"Synonym (ITY) 1793158-00 D1"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)