import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\h*[^ a-zA-Z\\n].*$";
final String string = "Go Forty Go (IRE) 471\n"
+ "Pearl Noir 15528258 D3\n"
+ "Synonym (ITY) 1793158-00 D1";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}