$re = '/\h*[^ a-zA-Z\n].*$/m';
$str = 'Go Forty Go (IRE) 471
Pearl Noir 15528258 D3
Synonym (ITY) 1793158-00 D1';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;