import Foundation
let pattern = #"\h*[^ a-zA-Z\n].*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Go Forty Go (IRE) 471
Pearl Noir 15528258 D3
Synonym (ITY) 1793158-00 D1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)