use strict;
my $str = 'Go Forty Go (IRE) 471
Pearl Noir 15528258 D3
Synonym (ITY) 1793158-00 D1';
my $regex = qr/\h*[^ a-zA-Z\n].*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";