package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\h*[^ a-zA-Z\n].*$`)
var str = `Go Forty Go (IRE) 471
Pearl Noir 15528258 D3
Synonym (ITY) 1793158-00 D1`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}