const regex = /\h*[^ a-zA-Z\n].*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\h*[^ a-zA-Z\\n].*$', 'gm')
const str = `Go Forty Go (IRE) 471
Pearl Noir 15528258 D3
Synonym (ITY) 1793158-00 D1`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);