# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\+?27/0/gm;t' <<< "012xxxxxxx
+27xxxxxxxx
011xxxxxxx
27xxxxxxxx"