using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\+?27";
string substitution = @"0";
string input = @"012xxxxxxx
+27xxxxxxxx
011xxxxxxx
27xxxxxxxx";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}