use strict;
my $str = '012xxxxxxx
+27xxxxxxxx
011xxxxxxx
27xxxxxxxx';
my $regex = qr/^\+?27/mp;
my $subst = '0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";