import Foundation
let pattern = #"^\+?27"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
012xxxxxxx
+27xxxxxxxx
011xxxxxxx
27xxxxxxxx
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)