re = /^\+?27/m
str = '012xxxxxxx
+27xxxxxxxx
011xxxxxxx
27xxxxxxxx'
subst = '0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result