const regex = new RegExp('^\\+?27', 'gm')
const str = `012xxxxxxx
+27xxxxxxxx
011xxxxxxx
27xxxxxxxx`;
const subst = `0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);