#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^127\.|^[0:]*::1[[:space:]]"
Local $sString = "127.0.0.1 localhost localhost.localdomain" & @CRLF & _
"127.0.1.1 mybox mybox.home" & @CRLF & _
"172.0.1.1 yourbox yourbox.office" & @CRLF & _
"1.2.127.1 127.box" & @CRLF & _
"::1 localhost mybox mybox.home" & @CRLF & _
"00::1 mybox.lo" & @CRLF & _
"12::1 invalid"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")