using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^127\.|^[0:]*::1[[:space:]]";
string input = @"127.0.0.1 localhost localhost.localdomain
127.0.1.1 mybox mybox.home
172.0.1.1 yourbox yourbox.office
1.2.127.1 127.box
::1 localhost mybox mybox.home
00::1 mybox.lo
12::1 invalid";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}