// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^127\.|^[0:]*::1[[:space:]]").unwrap();
let string = "127.0.0.1 localhost localhost.localdomain
127.0.1.1 mybox mybox.home
172.0.1.1 yourbox yourbox.office
1.2.127.1 127.box
::1 localhost mybox mybox.home
00::1 mybox.lo
12::1 invalid";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}