re = /^127\.|^[0:]*::1[[:space:]]/m
str = '127.0.0.1 localhost localhost.localdomain
127.0.1.1 mybox mybox.home
172.0.1.1 yourbox yourbox.office
1.2.127.1 127.box
::1 localhost mybox mybox.home
00::1 mybox.lo
12::1 invalid'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end