const regex = /^127\.|^[0:]*::1[[:space:]]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^127\\.|^[0:]*::1[[:space:]]', 'gm')
const str = `127.0.0.1 localhost localhost.localdomain
127.0.1.1 mybox mybox.home
172.0.1.1 yourbox yourbox.office
1.2.127.1 127.box
::1 localhost mybox mybox.home
00::1 mybox.lo
12::1 invalid`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}